Running OpenWRT on Soekris 4801

After looking for quite a while for different solutions for my local router box, i decided to use an Soekris 4801 box. There are several advantages for this:
  • It is fanless
  • It can be run with CF Cards
  • All hardware is supported by Open Source drivers
The 4801 has 3 ethernet ports using NatSemi DP8381 chips, which are (compared to the usual via chips) VLAN capable. Additional I bought a mini-PCI wireless card. First i had a RT61 based card, which i had problems with running Linux. Therefore i decided to buy another card, Atheros based. This one worked out of the box. I decided to run OpenWRT on my box, for several reasons:
  • support for OpenWRT is known to be quite good
  • it is Linux based
  • one can easyly install more software
For this box, i run SVN trunk on this box, which was, when i started based on release WhiteRussian. A short time later they started the development of Kamikaze, which was a mercy for me, the add-on package handling is really lovely. First i started with Nico's packages but I soon decided to compile my own system from source. The packages can be found here. One of harder parts (at least I found in the beginning) was the network configuration for the box, as OpenWRT default config still focuses on the Linksys WRT boxes. Therefore here comes my current config: /etc/config/network config interface loopback
option ifname lo option proto static option ipaddr 127.0.0.1 option netmask 255.0.0.0
config interface lan
option ifname eth1 option proto 'static' option ipaddr '10.9.0.1' option netmask '255.255.255.0'
config interface wan
option ifname eth0 option proto pppoe option username "myISPlogin" option password "s3cr3t"
config interface phone
option ifname eth2 option proto static option ipaddr 10.9.1.1 option netmask 255.255.255.0
config interface wlan
option ifname ath0 option proto static option ipaddr 10.9.2.1 option netmask 255.255.255.0
/etc/config/wireless config wifi-device wifi0
option type atheros option channel 8 option diversity 1 option distance 100 option txantenna 0 option rxantenna 0 option mode 11g
config wifi-iface
option device wifi0 option network wlan option mode ap option ssid myESSID option hidden 0 option encryption psk2 option key "iWILLnotTELLyou"

No TrackBacks

TrackBack URL: http://blog.zobel.ftbfs.de/cgi-bin/tb.cgi/78

Leave a comment

March 2014

Sun Mon Tue Wed Thu Fri Sat
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31